Type |
Changes |
By |
|
Updates for FileUpload 1.1-RC1. |
martinc
|
|
Added release notes for FileUpload 1.1. |
martinc
|
|
Update the User Guide to document the "right" way of using FileUpload 1.1, rather than the older, and thus deprecated, ways that are compatible with FileUpload 1.0. |
martinc
|
|
Add this change log, including all changes since the Commons FileUpload 1.0 release. |
martinc
|
|
Update Commons IO dependency to version 1.1. |
martinc
|
|
Add custom PMD configuration. |
martinc
|
|
Make inner exception classes static, which they should have been all along. |
martinc
|
|
Fix Checkstyle warnings. |
martinc
|
|
Remove Javadoc warnings. Fixes
FILEUPLOAD-29. Thanks to Rahul Akolkar . |
martinc
|
|
Build updates:
- Include NOTICE.txt in the jar file and distributions.
- Include xdocs in source distribution.
- Create MD5 checksums for distributions.
|
martinc
|
|
Add custom Checkstyle configuration. |
martinc
|
|
Update dependencies in POM, and add comments and scope. |
martinc
|
|
Standardise on @throws instead of having a mixture of that and @exception. |
martinc
|
|
Make DiskFileItem serializable. Thanks to Niall Pemberton for the suggestion and patch. Fixes
FILEUPLOAD-50. Thanks to Niall Pemberton . |
martinc
|
|
Make the temporary file names unique across class loader s, not just within them, by including a UID in the file name. |
martinc
|
|
Include the actual and permitted sizes in both the exception message and the exception itself. Fixes
FILEUPLOAD-77. |
martinc
|
|
If an explicit header encoding is not specified, use the one from the appropriate context (i.e. ServletRequest or ActionRequest). Fixes
FILEUPLOAD-13. |
martinc
|
|
Add getCharacterEncoding to the request context. |
martinc
|
|
Null check and case insensitivity fixes. Fixes
FILEUPLOAD-83. |
martinc
|
|
Web site updates:
- Add detail pages for Source Repository and Issue Tracking, based on those for IO and Validator.
- Improvements to FileUpload home page, based on similar recent changes to IO and Validator home pages.
- The Bugzilla component name has a space in it. Fix the URLs.
- Add an FAQ page, using the Maven plugin to generate it.
|
martinc
|
|
Fixes to POMs Fixes
COMMONSSITE-2. |
dion
|
|
Setting source and target for Java 1.3 |
mrdon
|
|
Fix typos in Javadoc code examples. Fixes
FILEUPLOAD-37. |
martinc
|
|
Fix typos in exception messages. |
martinc
|
|
Obtain request content type from container instead of headers. Fixes
FILEUPLOAD-5. |
martinc
|
|
New mock objects from Jetspeed-2, and new FileUpload test cases. |
sullis
|
|
added toString() methods |
sullis
|
|
Fix up the existing package.html file and add new ones for the newly introduced packages. Fairly minimal, but with a link to the user guide. |
martinc
|
|
Substantial refactoring and additions:
- The core package is now independent of servlet / portlet / other distinctions, as well as persistence schemes, other than deprecated classes and methods retained for backwards compatibility.
- Servlet specific functionality has been moved to a new 'servlet' package. Existing users should migrate to this as soon as possible, since the servlet specific functionality in the generic package will be removed in the release after FileUpload 1.1.
- Support for portlets (JSR 168) has been added, in a new 'portlet' package. This is not well tested at this point, and feedback would be very much appreciated. (This also resolves bug #23620.)
- The disk-based file item implementation has been moved into a 'disk' package, and renamed from Default* to Disk* to reflect what it really is. The Default* classes have been retained in the top level package for backwards compatibility, but are now deprecated, and will be removed in the release after FileUpload 1.1.
- The isMultipartRequest method is an unfortunate casualty of this refactoring. That method should really be moved to ServletFileUpload, but since the method is static, it can only exist in either FileUploadBase or ServletFileUpload. Backwards compatibility dictates the former for now, bu t the latter is the desired state, which implies some future breakage. Fair warning...
|
martinc
|
|
Specify the encoding (ISO-8859-1) when converting the boundary to a byte array. Fixes
FILEUPLOAD-4. |
martinc
|
|
Convert to Sun coding guidelines. |
martinc
|
|
DeferredFileOutputStream moved to Commons IO. |
martinc
|
|
Workaround for Mac IE5 bug. Thanks to Justin Sampson for the patch and tests for this vexing issue. Fixes
FILEUPLOAD-16. Thanks to Justin Sampson . |
martinc
|
|
Handle unquoted header parameters. Fixes
FILEUPLOAD-104. |
martinc
|
|
Some documentation on interaction with virus scanners. Fixes
FILEUPLOAD-78. |
martinc
|
|
More unit tests from Justin Sampson. Fixes
FILEUPLOAD-31. Thanks to Justin Sampson . |
martinc
|
|
Use FileCleaner from Commons IO to clean up temp files, rather than File.deleteOnExit(), which can cause serious problems in long-running processes. Fixes
FILEUPLOAD-95. |
martinc
|
|
Check that HTTP method is POST as part of multipart check. Fixes
FILEUPLOAD-53. |
martinc
|
|
Switch to Commons IO version of DeferredFileOutputStream. Adding IO as a dependency will allow us to take advantage of other classes in that component to fix additional FileUpload bugs. |
martinc
|
|
handle quoted boundary specification. Fixes
FILEUPLOAD-40. |
martinc
|
|
use case-independ ent comparisons for encoding types. Fixes
FILEUPLOAD-18. |
martinc
|
|
Fix comments to avoid break iterator complaints. |
martinc
|
|
Fix typos in comments. Thanks to Yuji Yamano . |
martinc
|
|
Add support for character sets specified for individual parts. Fixes
FILEUPLOAD-101. Thanks to Oleg Kalnichevski . |
martinc
|
|
Change to Apache License 2.0 |
scolebourne
|
|
Correct the comment for the no-args constructor to reflect the fact that a factory needs to be set before parsing uploads. Fixes
FILEUPLOAD-22. |
martinc
|
|
Collapse some all but duplicated code. |
martinc
|
|
Fix example showing FileItem.write to use a File object. Fixes
FILEUPLOAD-72. |
jmcnally
|
|
Check for null before attempting to close streams in write(). Fixes
FILEUPLOAD-21. Thanks to Peter Chase . |
martinc
|
|
Correction to sample code in the docs. Fixes
FILEUPLOAD-67. Thanks to Paul Dalton . |
martinc
|